Authorization failures

Incident Report for Npay

Resolved

There were authorization processing issues at Nets Finland acquirer side. The authorization processing had issues between 0:03 (UTC+2) and 3:30.
Posted 29 days ago. Feb 13, 2025 - 03:49 EET

Investigating

We are currently investigating this issue.
Posted 29 days ago. Feb 13, 2025 - 01:07 EET
This incident affected: Acquirer Connections (Nets Finland).