High rate of debit authorization failures
Incident Report for Npay
Resolved
All authorizations are working as expected.
Between 12:13-13:12 EET (Finnish time), authorizations were failing for Nordea cards.
The problem was external.
Posted Feb 16, 2024 - 14:46 EET
Monitoring
Error counts have come back down. Monitoring the situation closely. This problem was external.
Posted Feb 16, 2024 - 13:18 EET
Update
Amex is not affected.
Posted Feb 16, 2024 - 12:57 EET
Investigating
We are seeing a high rate of failed debit authorizations since 12:12 EET. Possibly a problem with some card issuer or acquirer. We are investigating.
Posted Feb 16, 2024 - 12:55 EET
This incident affected: Payment Backend and Acquirer Connections (Nets Finland, Elavon, Worldline, American Express).