Payment terminal transactions failing

Incident Report for Npay

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 13:07 EET

Monitoring

The issue has been located to a third party service, which now appears to be working normally again.
The authorization success rates are back to normal, and we are monitoring the situation.
Posted Mar 24, 2025 - 10:10 EET

Investigating

Some of the payment terminal transactions are failing. We are currently investigating the issue.
Posted Mar 24, 2025 - 09:48 EET
This incident affected: Payment Backend.