Finland authorization issue

Incident Report for Npay

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 18:39 EEST

Monitoring

There was an authorization incident 12:11–12:34, which has since resolved. Around 50-80% of authorizations for Finnish acquiring failed during that time. We are still investigating the root cause, but the issue is unlikely to repeat itself – but we will keep monitoring the situation.
Posted Apr 29, 2026 - 13:42 EEST

Investigating

12:11 Finland time - debit authorization degraded for Finnish acquiring.

12:11 alkaen katevarmennusyhteydessä ongelmia, selvitys käynnissä
Posted Apr 29, 2026 - 12:30 EEST
This incident affected: Acquirer Connections (Nets Finland).