Mobile network connectivity issues with payment terminals

Incident Report for Npay

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 17:29 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 15:54 EET

Update

Connections are reported operational
Posted Feb 04, 2026 - 14:11 EET

Update

The issue is being investigated with Telenor. If possible, connect the terminal through a mobile phone hotspot, or other means, while the problem continues. Some merchants have reported successful reconnection after rebooting the device.
Posted Feb 04, 2026 - 13:48 EET

Update

Payment terminals in Finland that use Telenor SIM for cellular connection are affected. Situation is being investigated.
Posted Feb 04, 2026 - 12:44 EET

Investigating

We are currently investigating this issue.
Posted Feb 04, 2026 - 12:19 EET
This incident affected: Cellular payment terminal connections (Telenor).