Amex settlements for merchants using the Nets Finland acquirer are delayed since March 31st

Incident Report for Npay

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 12:59 EEST

Update

All the delayed settlements have now been resubmitted. The acquirer has confirmed the delayed settlements were processed successfully, and are now awaiting payment.
We apologize for the trouble this has caused!
Posted Apr 02, 2025 - 12:58 EEST

Investigating

Settlements for Amex transactions for merchants using the Nets Finland acquirer are delayed since March 31st.
Authorizations are not affected, nor are settlements for any other card type or any other acquirer.
Posted Apr 01, 2025 - 11:02 EEST
This incident affected: Payment Backend.