Authorizations through Nets Finland are failing

Incident Report for Npay

Update

Updated incident impact estimate
Posted Sep 22, 2026 - 23:46 EEST

Identified

Authorizations are failing due to an ongoing issue at Nets Finland acquiring. We are tracking the issue.
Posted Sep 22, 2026 - 23:45 EEST
This incident affects: Acquirer Connections (Nets Finland).