Acquiring connectivity

Incident Report for Npay

Resolved

This incident has been resolved.
Posted May 07, 2025 - 16:35 EEST

Monitoring

Returned to normal since 12:38 Finland local time. Monitoring.
Posted May 07, 2025 - 13:06 EEST

Investigating

Since 11:26 local time in Finland, connectivity issue between PSP and acquiring system affecting payments for Finnish merchants.

We are investigating.
Posted May 07, 2025 - 11:38 EEST
This incident affected: Acquirer Connections (Nets Finland).