We are still in dialogue with our cellular service vendors to get the issue resolved.
If you are affected by this: If possible, we recommend using other available Internet options, like WiFi.
Posted Apr 30, 2026 - 07:27 EEST
Update
We are still in dialogue with our cellular service vendors to get the issue resolved.
If you are affected by this: If possible, we recommend using other available Internet options, like WiFi.
Posted Apr 27, 2026 - 12:08 EEST
Identified
Some Castles terminals in Finland that are connected to Telia phone network are affected by this issue. If possible, we recommend using other available Internet options, like WiFi.
We are working with our phone service providers to fix the issue.
Posted Apr 23, 2026 - 11:34 EEST
Investigating
We are currently investigating issue where some payment terminals using Cellular connections are having issues connecting to payment service provider.
Posted Apr 22, 2026 - 12:50 EEST
This incident affects: Cellular payment terminal connections (Telenor).