A test incident

Incident Report for Npay

Resolved

This incident has been resolved. All systems are operating normally.
Posted Jun 26, 2026 - 20:25 EEST

Investigating

This is just a test
Posted Jun 26, 2026 - 17:51 EEST
This incident affected: Online tools.