Intermittent problems with card payments
Incident Report for Npay
Resolved
No more problems seen.
Posted Feb 20, 2024 - 22:27 EET
Monitoring
Problems should be fixed, but still monitoring for any further issues.
Posted Feb 20, 2024 - 19:44 EET
Identified
There are intermittent problems with card payments affecting all acquirers. Up-to-date status about this is being posted here: https://www.nets.eu/Pages/operational-status.aspx
Posted Feb 20, 2024 - 18:12 EET
This incident affected: Acquirer Connections (Nets Finland, Elavon, Worldline).