Authorization failures

Incident Report for Npay

Resolved

Incident was resolved 07:00 EEST. Issue affected only a very small amount of transactions and was caused by network issues in a service provider's data center.
Posted Oct 15, 2025 - 07:26 EEST

Investigating

We are currently investigating authorization processing issues that affect some transactions. Issue started around 05.00 EEST
Posted Oct 15, 2025 - 06:20 EEST
This incident affected: Payment Backend.