Nordic acquiring outage

Incident Report for Npay

Update

Since 16:58 CEST / 17:58 EEST new Nordic acquiring outage affecting merchants in Nordics causing payments to fail.
Posted May 21, 2026 - 18:11 EEST

Investigating

Unfortunately, we are seeing failures again.
Posted May 21, 2026 - 18:08 EEST

Monitoring

The Nordic acquiring outage has been resolved. Card payments have been going through successfully since approximately 14:43 CEST / 15:43 EEST, and success rates are back to normal.

We are continuing to monitor the service to make sure it stays stable before closing the incident. No action is needed from merchants.

We apologise for the disruption and will post a final update once monitoring is complete.
Posted May 21, 2026 - 17:41 EEST

Update

We are continuing to work with highest priority on a fix for this issue.
Posted May 21, 2026 - 11:50 EEST

Identified

Nordic acquiring down since 10:06 EET / 9:06 CET.
Posted May 21, 2026 - 10:43 EEST

Investigating

We've identified an issue with Nordic acquiring affecting our terminals in Nordics.

I've escalated the issue.
Posted May 21, 2026 - 10:22 EEST
This incident affects: Acquirer Connections (Nets Denmark).