Settlements for merchants using the Nets Denmark (NDS) acquirer are delayed since March 25th

Incident Report for Npay

Resolved

The resubmitted settlements were confirmed as processed successfully by the acquirer, and are awaiting settlement. Again, we apologize for the trouble caused by this.
Posted Mar 28, 2025 - 17:58 EET

Update

The failed batches have been resubmitted to the acquirer, and we are awaiting confirmation of their successful processing. We apologize for the trouble caused by this.
Posted Mar 28, 2025 - 16:13 EET

Monitoring

The fix for newly created settlements was confirmed working. Work is still ongoing for resubmitting the failed settlements.
Posted Mar 28, 2025 - 09:54 EET

Identified

The issue was identified, and a fix has been applied for newly created settlements. A fix for the delayed settlements is currently being validated, but has not yet been applied.
Posted Mar 27, 2025 - 17:33 EET

Investigating

Settlements for merchants using the Nets Denmark acquirer are delayed since March 25th.
This delay doesn't affect authorizations nor does it affect any other acquirer's settlements.

We are investigating this issue.
Posted Mar 27, 2025 - 14:32 EET
This incident affected: Payment Backend.