Elevated error rates for authorizations

Incident Report for Npay

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 01:51 EET

Monitoring

Acquirer is reporting issue as resolved, and we are no longer seeing failed authorizations
Posted Jan 19, 2026 - 23:48 EET

Update

Ongoing issue was confirmed with Nets Finland acquiring, we are awaiting further information
Posted Jan 19, 2026 - 22:07 EET

Investigating

We are currently investigating elevated error rates for authorizations going through Nets Finland acquiring
Posted Jan 19, 2026 - 21:48 EET
This incident affected: Acquirer Connections (Nets Finland).