Worldline settlements delayed
Incident Report for Npay
Resolved
All delayed settlements have now been delivered.
Posted Sep 19, 2023 - 14:58 EEST
Investigating
This affects every merchant that is routed via TietoEvry.
We are currently investigating the issue.
Posted Sep 18, 2023 - 12:19 EEST
This incident affected: Acquirer Connections (Worldline).